Skip to main content

CCIE Routing Protocols and Multicast Notes Reminder

As I have encountered lately with numerous questions regarding Routing Protocols using multicast I have some reminder notes: 1 ) Multicast is a destination Address, mean you will never see it in the SA of a Packet. 2) Routing Protocols Such as RIPv2 , OSPF , EIGRP use multicast by default although you can set them to other then the neture behavior 3) RIPv2 224.0.0.9 / OSPF 224.0.0.5 (All OSPF Router) 224.0.0.6 (All DR/BDR) EIGRP 224.0.0.10 4) Address range 224.0.0.1 - 224.0.0.254 are non routeable address, and you ask your self how can a routing protocol use a non routable address or what is non routeable address A) non-routeable address is when a packet is living one router and reaching his nexthop router the next hop will not send it further but he will recreate another packet if he need to update others B) So when we understand what is non-routeable address we hopefully understand why a routing protocol do not need a routeable address, as you send an update you know only your next hope (or as i call it your continues address) and you cant know what is beoned that unless you get an update on that. C) what brings us to another important rule the router that get the update never send back the same update trough the same interface he received it, and this is as you know preventing routing loops or as we call it "SPLIT HORIZON" 5) also regarding continues networks in addition to all the above if you want to form a neighbor relation with another router, in addition to the specific rules of each protocol, you must be either connected directly (same subnet) or make the router think you are directly connected (by using a tunnel interface). and why you ask because of the simple fact that if I don't know how to get to you in the first place how can i make a neighbor relation as you know we are talking about IGP internal routing protocols and not BGP that you can use the multi hop (but that's for another article). I hope this has been some interesting and helpful information.
Post a Comment

Popular posts from this blog

Step By Step MPLS – Basic MPLS Setup

Initial configuration , very basic with no MPLS, connectivity only to directly connected interfaces.R1R2R3R4!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.31.1 255.255.255.0
duplex auto
speed auto
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.42.2 255.255.255.0
duplex auto
speed auto
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
ip address 10.0.31.3 255.255.255.0
duplex auto
speed auto
  no clns route-cache
!
interface Serial1/0
ip address 10.0.43.3 255.255.255.0
  serial restart-delay 0
no clns route-cache
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
ip address 10.0.42.4 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
ip address 10.0.43.4 255.255.255.0
  serial restart-delay 0
no clns route-cache
!
adding to the following configuration MPLS labels we will start wi…

What is about to change in CISSP from Apr 2018

Change have arrived and like with other professional certification there is almost a standard time before certification gets its update, with most anywhere it is between 3 - 4 years, CISSP is no different and since last update was on 2015 the change is arriving here as well.

For the people that wish to see the official existing and new outline

I have decided to write this post as the new out line is more of a list of Domain and Sections within the domain without hint or indication to what was modified actually and I could not find anyone else that done that comparison, I had to take the task and do the comparison, please be advised that I have done it for my own "pleasure" so apologies if I missed something :-)
Lets start with the obvious change:
CISSP - Before Apr 2018CISSP - from Apr 20181. Security and Risk Management16%15%2. Asset Security10%10%3. Security Engineering12%13%4. Communications and Network Security12%14%5. Identity and Access Management13%13%6. …

VRF Maximum Routes

Maximum routes under customer vrf, if the service provider had unlimited resources he would not have needed that!
however normally resources are limited and expensive, and Service provider would like to make money from his available resources. maximum routes configured under VRF provide a mean of controlling PE local resource and abuse avoidance from the CE side.I have vrf called DC_EXTRANET, you can see that I have 16 routes, I have configured 10 maximum routes under that vrf however I did not want to be aggressive so I have set the warning only option. See that immediately I get a notice that I have more routes then the maximum, however no action is taken other then alerting and sending a syslog. ! PE_ashdod_otherisp.n(config-vrf)# maximum routes 10 warning-only % The current number of routes in the routing table is equal to, or exceeds the configured warning limit PE_ashdod_otherisp.n(config-vrf)# *Nov 26 20:39:41.175: %IPRT-3-ROUTELIMITWARNING: IP routing table limit warning - DC_…