Skip to main content
Although I am taking the R&S Lab Exam my vast Experience is mainly i VOIP, I work for ~7 years with VoIP Company's and in the last 5 Years in the same Group Z-Group I have worked in the past years with more then 500 Carriers and with that I believe that I have the privileged to talk about it a little bit. As the Sys Admin in my company I have been loyal to Cisco Class 4 Equipment (mostly AS5300 AS5350 and AS5350XM I have also worked with MG200 AS5400 AS5800 and the small 26xx and 36xx), QoS is one of the major topics in the VoIP env as there is a growing number of Bandwidth Consuming Applications.in my company I am considering the QoS planing and deploying one of the most important part of deploying a successful and friendly VoIP Env. QoS is a way to make your network bandwidth utilization optimized without investing more bandwidth or separate env for voice and data. When you say that your network is full you should consider taking a survey see what is passing trough your network, one of the most usful tools I am using today is NBAR (Network Based Application Recognition)nbar is using PDLM (Protocol description Language Module) or in other words pre defined scripts that enabling the Cisco to recognize Applications and Protocols passing trough the Machine One of the first steps to deploy QoS is to recognize and define your traffic and some use also the term color your traffic. when you have colored traffic it is very easy to play with it, like we use tagging (mostly in OSPF) we can tag this is RTP that is P2P and so on...and after you have Classified your traffic you can say for example: if I want to give RTP priority over everything else I want to Drop P2P if they use more then 20KbpsI want to random detect (Work only with TCP called also WRED) and drop low classified packets randomly so I will not pass the threshold of allowed bandwidth. QoS allow us to set Queuing and Priorities to traffic patterns and that way: 1) Assuring important traffic over low important traffic 2) Allowing Administrator identify problems during and also before the happen 3) in some way also adding some security policy as you can defign that all P2P or IM should be Dropped and not allowed Most business's consider such applications as work disturbing Few Things regarding NBAR as it is grate it also has one major disadvantage, it is CPU consuming task and if you have already busy router you will have a problem, note that hardware issues are also one of the problems in achieving QoS. you must know your equipment and its capabilities. For now I will conclude this section of QoS and soon I will add part 2 to this with more notes mainly on Voice today and different types of implementations Scenarios.
Post a Comment

Popular posts from this blog

Step By Step MPLS – Basic MPLS Setup

Initial configuration , very basic with no MPLS, connectivity only to directly connected interfaces.R1R2R3R4!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.31.1 255.255.255.0
duplex auto
speed auto
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.42.2 255.255.255.0
duplex auto
speed auto
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
ip address 10.0.31.3 255.255.255.0
duplex auto
speed auto
  no clns route-cache
!
interface Serial1/0
ip address 10.0.43.3 255.255.255.0
  serial restart-delay 0
no clns route-cache
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
ip address 10.0.42.4 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
ip address 10.0.43.4 255.255.255.0
  serial restart-delay 0
no clns route-cache
!
adding to the following configuration MPLS labels we will start wi…

VRF Maximum Routes

Maximum routes under customer vrf, if the service provider had unlimited resources he would not have needed that!
however normally resources are limited and expensive, and Service provider would like to make money from his available resources. maximum routes configured under VRF provide a mean of controlling PE local resource and abuse avoidance from the CE side.I have vrf called DC_EXTRANET, you can see that I have 16 routes, I have configured 10 maximum routes under that vrf however I did not want to be aggressive so I have set the warning only option. See that immediately I get a notice that I have more routes then the maximum, however no action is taken other then alerting and sending a syslog. ! PE_ashdod_otherisp.n(config-vrf)# maximum routes 10 warning-only % The current number of routes in the routing table is equal to, or exceeds the configured warning limit PE_ashdod_otherisp.n(config-vrf)# *Nov 26 20:39:41.175: %IPRT-3-ROUTELIMITWARNING: IP routing table limit warning - DC_…

ISIS Database Reading

ISIS is simple to operate normally while everything is working, most common deployments are flat network based on L2, however when there is a problem and we need to start troubleshooting then people start to get lost.So I would like to provide some tools on how to read ISIS database.notice to the “*” sign, that mean LSP was generated on the router you did the show command, you can see that host name from the show command match also host name on the LSPID,LSPID identified by hostname.xx-yy,  xx is normally 00 unless that LSP is pseudo node LSP generated by DIS , yy is representing the number of fragments for that LSP 00 – FF (max 255 fragments, plenty), most cases all the important information will be in 00 unless there are many fragments.LSP Holdtime is the amount of time an LSP will stay in database without any refresh.ATT/P/OL - 0/0/0, ATT bit or attached bit is used on L1/L2 connected to L1 node, if set to 1 L1 node will generate default route to the best L1/L2 node (best metric)AT…